Why does my Unicode Dyalog stop giving APL characters?

The Dyalog "Knowledgebase". This forum is read-only
Forum rules
The FAQ is a read-only forum which is in general updated only by employees of Dyalog Ltd. It replaces the FAQ page which existed under http://www.dyalog.com. Rather than rejecting other posts to this forum, such posts will be put in a moderation queue, and moved to a more appropriate forum.

Why does my Unicode Dyalog stop giving APL characters?

Postby Vince|Dyalog on Fri Sep 10, 2010 8:35 am

If it appears that our Unicode keyboard input stops working as you no longer get APL characters as you normally do, you may have Ctrl+Shift set up as an accelerator to switch between keyboard layouts. This may be the default for Windows. If you hit Ctrl+Shift again, you should continue to cycle through the keyboards that are installed. To remove or change the accelerator, look in:

Step 1:
Windows 10:
Settings=>Time & language=>Scroll down to the bottom of the dialog=>Additional date, time & regional Settings. =>Change input methods=>Advanced Settings=>Change language bar hot keys

Windows 8/8.1:
Control Panel => Language => Advanced Settings => Change language bar hotkeys => Advanced Key Settings

Windows Vista/Windows 7:
Control Panel => Region and Language => Keyboards and Languages => Change Keyboards... => Advanced Key Settings

Windows XP:
Control Panel/Regional and Language Options/Languages
Press the Details button.
Then, look at Key Settings.

Step 2:
For all versions of Windows:
Press the Change Key Sequence... button.


You may prefer to alter the values for "Switch Input Language" to "Not Assigned" and "Switch Keyboard Layout" to "Left Alt + Shift" so that you can still switch between keyboard layouts, but not have problems when accidentally hitting "Ctrl + Shift" on their own
Vince|Dyalog
 
Posts: 265
Joined: Wed Oct 01, 2008 9:39 am

Return to Frequently Asked Questions (FAQ)

Who is online

Users browsing this forum: No registered users and 2 guests