Dyalog (Unicode) Problem typing APL characters on Windows 8?

The Dyalog "Knowledgebase". This forum is read-only
Forum rules
The FAQ is a read-only forum which is in general updated only by employees of Dyalog Ltd. It replaces the FAQ page which existed under http://www.dyalog.com. Rather than rejecting other posts to this forum, such posts will be put in a moderation queue, and moved to a more appropriate forum.

Dyalog (Unicode) Problem typing APL characters on Windows 8?

Postby Vince|Dyalog on Thu Feb 07, 2013 1:16 pm

[Edited by Andy 2013-11-22]

You can have problems typing APL characters into Dyalog on Windows 8. You might not be able to type them upon first starting Dyalog, or you lose the ability to do so if you focus on another window and then back to Dyalog.

I've found that the following will solve the problem:

Click on Settings and then click on Control Panel

If you are viewing the folder by Category, choose "Change Input methods".
If you are viewing by Icons, choose Language

Click on "Advanced Settings"

Ensure that "Let me set a different input method for each app window" is ticked.

Click on Save and exit the Control Panel.

Start Dyalog.

Click on "Options->Configure->Unicode Input"

Ensure "Activate selected keyboard" is ticked

In the Keyboard combo box, select a Dyalog APL IME which corresponds to your
language and region.

Click on OK

Exit and restart Dyalog.

Do you get APL characters if you do Ctrl+a or Ctrl+i?

2013-11-22: Andy adds: you might also like to take a look at http://www.dyalog.com/forum/viewtopic.php?f=22&t=204 which explains one reason why you might lose the ability to enter APL characters, and a configuration change which will stop that happening. This applies to all versions Windows from XP onwards.
Vince|Dyalog
 
Posts: 238
Joined: Wed Oct 01, 2008 9:39 am

Return to Frequently Asked Questions (FAQ)

Who is online

Users browsing this forum: No registered users and 1 guest